R1#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.1.12.1       YES manual up                    up     
Serial0/1                  10.1.13.1       YES manual up                    up     
Serial0/2                  10.1.14.1       YES manual up                    up     
Serial0/3                  unassigned      YES unset  administratively down down   
Loopback0                  1.1.1.1         YES manual up                    up     

R2#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.1.12.2       YES manual up                    up     

R3#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.1.13.3       YES manual up                    up   

R4#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.1.14.4       YES manual up                    up     
Serial0/1                  10.1.45.4       YES manual up                    up     

R5#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.1.45.5       YES manual up                    up     
Serial0/1                  unassigned      YES unset  administratively down down   
Serial0/2                  unassigned      YES unset  administratively down down   
Serial0/3                  unassigned      YES unset  administratively down down   
Loopback1                  2.2.2.2         YES manual up                    up     
Loopback2                  3.3.3.3         YES manual up                    up
R1(config)#router eigrp 100
R1(config-router)#net 1.1.1.1 0.0.0.0
R1(config-router)#net 10.1.12.1 0.0.0.0
R1(config-router)#net 10.1.13.1 0.0.0.0
R1(config-router)#net 10.1.14.1 0.0.0.0
R1(config-router)#no au

R2(config)#router eigrp 100
R2(config-router)#net 10.1.12.2 0.0.0.0
R2(config-router)#no au

R3(config)#router eigrp 100
R3(config-router)#net 10.1.13.3 0.0.0.0
R3(config-router)#no au

R4(config)#router eigrp 100
R4(config-router)#net 10.1.14.4 0.0.0.0
R4(config-router)#no au
R4(config-router)#exit

R4(config)#router ospf 1 
R4(config-router)#net 10.1.45.4 0.0.0.0 a 0
R4(config-router)#no au
R4(config-router)#end

R5(config)#router ospf 1
R5(config-router)#net 10.1.45.5 0.0.0.0 a 0
R5(config-router)#net 2.2.2.2 0.0.0.0 a 0
R5(config-router)#net 3.3.3.3 0.0.0.0 a 0
R5(config-router)#no au
R5(config-router)#end

R4(config)#router ospf 1
R4(config-router)#redistribute eigrp 100 subnets
R4(config-router)#end

R4(config)#router eigrp 100
R4(config-router)#redistribute ospf 1 metric 1544 20000 255 1 1500
R4(config-router)#end

R4#sho ip route

     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/2297856] via 10.1.14.1, 00:00:53, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/1563] via 10.1.45.5, 00:05:46, Serial0/1
     3.0.0.0/24 is subnetted, 1 subnets
O       3.3.3.0 [110/1563] via 10.1.45.5, 00:05:46, Serial0/1
     10.0.0.0/24 is subnetted, 4 subnets
C       10.1.14.0 is directly connected, Serial0/0
D       10.1.13.0 [90/2681856] via 10.1.14.1, 00:00:53, Serial0/0
D       10.1.12.0 [90/2681856] via 10.1.14.1, 00:00:53, Serial0/0
C       10.1.45.0 is directly connected, Serial0/1


R1#sho ip route

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
D EX    2.2.2.2 [170/7289856] via 10.1.14.4, 00:00:16, Serial0/2
     3.0.0.0/24 is subnetted, 1 subnets
D EX    3.3.3.0 [170/7289856] via 10.1.14.4, 00:00:16, Serial0/2
     10.0.0.0/24 is subnetted, 4 subnets
C       10.1.14.0 is directly connected, Serial0/2
C       10.1.13.0 is directly connected, Serial0/1
C       10.1.12.0 is directly connected, Serial0/0
D EX    10.1.45.0 [170/7289856] via 10.1.14.4, 00:00:19, Serial0/2

R1(config)#router eigrp 100
R1(config-router)#eigrp stub connected leak-map TST


R1(config)#access-list 2 permit 2.2.2.0 0.0.0.255
R1(config)#access-list 3 permit 3.3.3.0 0.0.0.255

R1(config)#route-map TST permit 10
R1(config-route-map)#match ip address 2
R1(config-route-map)#match interface serial 0/0
R1(config-route-map)#exit

R1(config)#route-map TST permit 20
R1(config-route-map)#match ip address 3
R1(config-route-map)#match interface serial 0/1
R1(config-route-map)#end

R2#sho ip route

     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/2297856] via 10.1.12.1, 00:18:21, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
D EX    2.2.2.2 [170/7801856] via 10.1.12.1, 00:16:57, Serial0/0
     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.14.0 [90/2681856] via 10.1.12.1, 00:18:21, Serial0/0
D       10.1.13.0 [90/2681856] via 10.1.12.1, 00:18:21, Serial0/0
C       10.1.12.0 is directly connected, Serial0/0


R2#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R2#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 120/131/164 ms

R3#sho ip route

1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/2297856] via 10.1.13.1, 00:18:16, Serial0/0
     3.0.0.0/24 is subnetted, 1 subnets
D EX    3.3.3.0 [170/7801856] via 10.1.13.1, 00:15:41, Serial0/0
     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.14.0 [90/2681856] via 10.1.13.1, 00:18:16, Serial0/0
C       10.1.13.0 is directly connected, Serial0/0
D       10.1.12.0 [90/2681856] via 10.1.13.1, 00:18:16, Serial0/0

R3#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/130/156 ms
     

0 comments:

Post a Comment

 
Top