R1#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.12.1       YES manual up                    up     
Loopback0                  1.1.1.1         YES manual up                    up     
Loopback1                  11.11.11.11     YES manual up                    up   

R2#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.12.2       YES manual up                    up     
FastEthernet1/0            10.1.23.2       YES manual up                    up     
Loopback0                  2.2.2.2         YES manual up                    up    

R3#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.23.3       YES manual up                    up     
Loopback0                  3.3.3.3         YES manual up                    up     

R1(config)#router eigrp 100
R1(config-router)#net 1.1.1.0 0.0.0.255
R1(config-router)#net 11.11.11.0 0.0.0.255 
R1(config-router)#net 10.1.12.0 0.0.0.255
R1(config-router)#no au

R2(config)#router eigrp 100
R2(config-router)#net 2.2.2.0 0.0.0.255
R2(config-router)#net 10.1.12.0 0.0.0.255
R2(config-router)#no au
R2(config-router)#exit
R2(config)#router eigrp 200
R2(config-router)#net 10.1.23.0 0.0.0.255 
R2(config-router)#no au
R3(config)#router eigrp 200
R3(config-router)#net 3.3.3.0 0.0.0.255
R3(config-router)#net 10.1.23.0 0.0.0.255
R3(config-router)#no au

R1(config)#key chain t3
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string 3t
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#int fa0/0
R1(config-if)#ip authentication mode eigrp 100 md5
R1(config-if)#ip authentication key-chain eigrp 100 t3
R1(config-if)#
R1(config-if)#end

R2(config)#key chain t3
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string 3t
R2(config-keychain-key)#end
R2#conf t
R2(config)#int fa0/0
R2(config-if)#ip authentication mode eigrp 100 md5
R2(config-if)#ip authentication key-chain eigrp 100 t3
R2(config-if)#
R2(config-if)#end

R2(config)#router eigrp 100
R2(config-router)#redistribute eigrp 200 route-map to_eigrp100
R2(config-router)#exit    
R2(config)#router eigrp 200
R2(config-router)#redistribute eigrp 100 route-map to_eigrp200
R2(config-router)#distribute-list 1 out
R2(config-router)#
R2(config-router)#exit 
R2(config)#no ip http server
R2(config)#no ip http secure-server
R2(config)#ip forward-protocol nd
R2(config)#route-map to_eigrp100 deny 10
R2(config-route-map)#match tag 100
R2(config-route-map)#exit
R2(config)#route-map to_eigrp100 permit 20
R2(config-route-map)#set tag 200
R2(config-route-map)#exit
R2(config)#route-map to_eigrp200 deny 10
R2(config-route-map)#match tag 200
R2(config-route-map)#exit
R2(config)#route-map to_eigrp200 permit 20
R2(config-route-map)#set tag 100
R3#ping 1.1.1.1   

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/80/96 ms

R3#ping 11.11.11.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/84/96 ms

R2(config)#access-list 1 deny 11.11.11.0 0.0.0.255
R2(config)#access-list 1 permit any 

R3#ping 11.11.11.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


R3#ping 1.1.1.1   

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/64/64 ms

R2#sho ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.12.1               Fa0/0             12 00:17:01  330  1980  0  11
IP-EIGRP neighbors for process 200
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.23.3               Fa1/0              9 00:15:37   50   300  0  11

0 comments:

Post a Comment

 
Top