1(config)#do sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                10.1.12.1       YES NVRAM  up                    up     
Ethernet0/1                10.1.14.1       YES NVRAM  up                    up     
Ethernet0/2                10.1.16.1       YES NVRAM  up                    up     
Ethernet0/3                10.1.17.1       YES NVRAM  up                    up     
Loopback0                  1.1.1.1         YES NVRAM  up                    up     

R2#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                10.1.12.2       YES NVRAM  up                    up     
Ethernet0/1                10.1.23.2       YES NVRAM  up                    up     
Ethernet0/2                10.1.25.2       YES NVRAM  up                    up     
Loopback0                  2.2.2.2         YES NVRAM  up                    up     

R3#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                10.1.23.3       YES NVRAM  up                    up     
Loopback0                  3.3.3.3         YES NVRAM  up                    up     

R4#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                10.1.14.4       YES NVRAM  up                    up     
Loopback0                  4.4.4.4         YES NVRAM  up                    up
R5#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Loopback0                  5.5.5.5         YES NVRAM  up                    up  

R6#sho ip int bri
Interface                  IP-Address      OK? Method Status                Protocol
Loopback0                  6.6.6.6         YES NVRAM  up                    up    

R1#sho run | s bgp
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 10.1.12.2 remote-as 200
 neighbor 10.1.14.4 remote-as 100
 neighbor 10.1.16.6 remote-as 100
 neighbor 10.1.23.3 remote-as 100
 no auto-summary

R4#sho run | s bgp
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.0 mask 255.255.255.0
 neighbor 10.1.14.1 remote-as 100
 neighbor 10.1.16.6 remote-as 100
 neighbor 10.1.23.3 remote-as 100
 no auto-summary

R6#sho run | s bgp
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 6.6.6.0 mask 255.255.255.0
 neighbor 10.1.14.4 remote-as 100
 neighbor 10.1.16.1 remote-as 100
 neighbor 10.1.23.3 remote-as 100
 no auto-summary

R3#sho run | s bgp
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.0 mask 255.255.255.0
 neighbor 10.1.12.1 remote-as 100
 neighbor 10.1.14.4 remote-as 100
 neighbor 10.1.16.6 remote-as 100
 neighbor 10.1.23.2 remote-as 200
 no auto-summary
R1#sho ip bgp sum
R1#sho ip bgp summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 4, main routing table version 4
3 network entries using 351 bytes of memory
3 path entries using 156 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 879 total bytes of memory
BGP activity 3/0 prefixes, 3/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.1.12.2       4   200       0       0        0    0    0 never    Active
10.1.14.4       4   100      17      17        4    0    0 00:13:06        1
10.1.16.6       4   100      17      17        4    0    0 00:12:11        1
10.1.23.3       4   100       0       0        0    0    0 never    Active

R1#sh ip bgp
BGP table version is 4, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       0.0.0.0                  0         32768 i
*>i4.4.4.0/24       10.1.14.4                0    100      0 i
*>i6.6.6.0/24       10.1.16.6                0    100      0 i

R1#sho ip route bgp
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [200/0] via 10.1.14.4, 00:13:20
     6.0.0.0/24 is subnetted, 1 subnets
B       6.6.6.0 [200/0] via 10.1.16.6, 00:13:14

R4#sho ip bgp summary
BGP router identifier 4.4.4.4, local AS number 100
BGP table version is 3, main routing table version 3
2 network entries using 234 bytes of memory
2 path entries using 104 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 710 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.1.14.1       4   100      18      18        3    0    0 00:14:29        1
10.1.16.6       4   100       0       0        0    0    0 never    Active
10.1.23.3       4   100       0       0        0    0    0 never    Active

R4#sho ip bgp
BGP table version is 3, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       10.1.14.1                0    100      0 i
*> 4.4.4.0/24       0.0.0.0                  0         32768 i

R4#sho ip  route bgp
     1.0.0.0/24 is subnetted, 1 subnets
B       1.1.1.0 [200/0] via 10.1.14.1, 00:13:48

R6#sho ip bgp summary
BGP router identifier 6.6.6.6, local AS number 100
BGP table version is 3, main routing table version 3
2 network entries using 234 bytes of memory
2 path entries using 104 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 710 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.1.14.4       4   100       0       0        0    0    0 never    Active
10.1.16.1       4   100      19      19        3    0    0 00:14:33        1
10.1.23.3       4   100       0       0        0    0    0 never    Active

R6#sho ip bgp
BGP table version is 3, local router ID is 6.6.6.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       10.1.16.1                0    100      0 i
*> 6.6.6.0/24       0.0.0.0                  0         32768 i

R6#sho ip route bgp
     1.0.0.0/24 is subnetted, 1 subnets
B       1.1.1.0 [200/0] via 10.1.16.1, 00:14:41

R1#sho run | s rip
router rip
 version 2
 network 10.0.0.0
 no auto-summary

R4#sho run | s rip
router rip
 version 2
 network 10.0.0.0
 no auto-summary

router rip
 version 2
 network 10.0.0.0
 no auto-summary

R4#sho ip route bgp
     1.0.0.0/24 is subnetted, 1 subnets
B       1.1.1.0 [200/0] via 10.1.14.1, 00:25:00
     6.0.0.0/24 is subnetted, 1 subnets
B       6.6.6.0 [200/0] via 10.1.16.6, 00:01:21

R4#sho ip bgp
BGP table version is 4, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       10.1.14.1                0    100      0 i
*> 4.4.4.0/24       0.0.0.0                  0         32768 i
*>i6.6.6.0/24       10.1.16.6                0    100      0 i

R4#ping 6.6.6.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/25/36 ms

R2#sho run | s bgp
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.0 mask 255.255.255.0
 neighbor 10.1.12.1 remote-as 100
 neighbor 10.1.23.3 remote-as 100
 neighbor 10.1.25.5 remote-as 200
 no auto-summary

R5#sho run | s bgp
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 5.5.5.0 mask 255.255.255.0
 neighbor 10.1.25.2 remote-as 200
 no auto-summary

Before Next-Hop-Self

R1#sho ip bgp
BGP table version is 6, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       0.0.0.0                  0         32768 i
*> 2.2.2.0/24       10.1.12.2                0             0 200 i
*>i4.4.4.0/24       10.1.14.4                0    100      0 i
*> 5.5.5.0/24       10.1.12.2                              0 200 i
*>i6.6.6.0/24       10.1.16.6                0    100      0 i

R2#sho ip bgp
BGP table version is 6, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       10.1.12.1                0             0 100 i
*> 2.2.2.0/24       0.0.0.0                  0         32768 i
*> 3.3.3.0/24       10.1.23.3                0             0 100 i
*> 4.4.4.0/24       10.1.12.1                              0 100 i
*> 6.6.6.0/24       10.1.12.1                              0 100 i

R2#sho ip route bgp
     1.0.0.0/24 is subnetted, 1 subnets
B       1.1.1.0 [20/0] via 10.1.12.1, 00:01:34
     3.0.0.0/24 is subnetted, 1 subnets
B       3.3.3.0 [20/0] via 10.1.23.3, 00:01:34
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [20/0] via 10.1.12.1, 00:01:34
     5.0.0.0/24 is subnetted, 1 subnets
B       5.5.5.0 [200/0] via 10.1.25.5, 00:00:30
     6.0.0.0/24 is subnetted, 1 subnets
B       6.6.6.0 [20/0] via 10.1.12.1, 00:01:34
R5#sho ip bgp
BGP table version is 3, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
* i1.1.1.0/24       10.1.12.1                0    100      0 100 i
*>i2.2.2.0/24       10.1.25.2                0    100      0 i
* i3.3.3.0/24       10.1.23.3                0    100      0 100 i
* i4.4.4.0/24       10.1.12.1                0    100      0 100 i
*> 5.5.5.0/24       0.0.0.0                  0         32768 i
* i6.6.6.0/24       10.1.12.1                0    100      0 100 i
R5#sho ip route bgp
     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [200/0] via 10.1.25.2, 00:00:58

R4#sho ip bgp
BGP table version is 6, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       10.1.14.1                0    100      0 i
*>i2.2.2.0/24       10.1.12.2                0    100      0 200 i
*> 4.4.4.0/24       0.0.0.0                  0         32768 i
*>i5.5.5.0/24       10.1.12.2                0    100      0 200 i
*>i6.6.6.0/24       10.1.16.6                0    100      0 i

R4#sho ip route bgp
     1.0.0.0/24 is subnetted, 1 subnets
B       1.1.1.0 [200/0] via 10.1.14.1, 00:36:16
     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [200/0] via 10.1.12.2, 00:07:38
     5.0.0.0/24 is subnetted, 1 subnets
B       5.5.5.0 [200/0] via 10.1.12.2, 00:06:34
     6.0.0.0/24 is subnetted, 1 subnets
B       6.6.6.0 [200/0] via 10.1.16.6, 00:12:37

R6#sho ip bgp
BGP table version is 6, local router ID is 6.6.6.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       10.1.16.1                0    100      0 i
*>i2.2.2.0/24       10.1.12.2                0    100      0 200 i
*>i4.4.4.0/24       10.1.14.4                0    100      0 i
*>i5.5.5.0/24       10.1.12.2                0    100      0 200 i
*> 6.6.6.0/24       0.0.0.0                  0         32768 i

After Next-Hop_Self

R1#sho run | s bgp
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 10.1.12.2 remote-as 200
 neighbor 10.1.14.4 remote-as 100
 neighbor 10.1.14.4 next-hop-self
 neighbor 10.1.16.6 remote-as 100
 neighbor 10.1.16.6 next-hop-self
 neighbor 10.1.23.3 remote-as 100

R2#sho run | s bgp
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.0 mask 255.255.255.0
 neighbor 10.1.12.1 remote-as 100
 neighbor 10.1.23.3 remote-as 100
 neighbor 10.1.25.5 remote-as 200
 neighbor 10.1.25.5 next-hop-self
 no auto-summary

R4#sho ip bgp
BGP table version is 8, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       10.1.14.1                0    100      0 i
*>i2.2.2.0/24       10.1.14.1                0    100      0 200 i
*> 4.4.4.0/24       0.0.0.0                  0         32768 i
*>i5.5.5.0/24       10.1.14.1                0    100      0 200 i
*>i6.6.6.0/24       10.1.16.6                0    100      0 i

R4#ping 5.5.5.5 source lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
Packet sent with a source address of 4.4.4.4
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/48/80 ms
R3(config)#router bgp 100
R3(config-router)#redistribute connected
R3(config-router)#end
R5#sho ip bgp
BGP table version is 8, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       10.1.25.2                0    100      0 100 i
*>i2.2.2.0/24       10.1.25.2                0    100      0 i
*>i3.3.3.0/24       10.1.25.2                0    100      0 100 i
*>i4.4.4.0/24       10.1.25.2                0    100      0 100 i
*> 5.5.5.0/24       0.0.0.0                  0         32768 i
*>i6.6.6.0/24       10.1.25.2                0    100      0 100 i
*>i10.1.23.0/24     10.1.25.2                0    100      0 100 ?
R3#sho ip bgp
BGP table version is 5, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       10.1.23.2                0             0 200 i
*> 3.3.3.0/24       0.0.0.0                  0         32768 i
*> 5.5.5.0/24       10.1.23.2                              0 200 i
*> 10.1.23.0/24     0.0.0.0                  0         32768 ?


R7#sho run | s bgp
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 7.7.7.0 mask 255.255.255.0
 neighbor 10.1.17.1 remote-as 100
 no auto-summary

R7#sho ip bgp
BGP table version is 3, local router ID is 7.7.7.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       10.1.17.1                0    100      0 i
* i2.2.2.0/24       10.1.12.2                0    100      0 200 i
* i5.5.5.0/24       10.1.12.2                0    100      0 200 i
*> 7.7.7.0/24       0.0.0.0                  0         32768 i

After Route Reflector

R1(config-router)#neighbor 10.1.17.7 route-reflector-client

R7#sho ip bgp    
BGP table version is 5, local router ID is 7.7.7.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       10.1.17.1                0    100      0 i
* i2.2.2.0/24       10.1.12.2                0    100      0 200 i
* i4.4.4.0/24       10.1.14.4                0    100      0 i
* i5.5.5.0/24       10.1.12.2                0    100      0 200 i
* i6.6.6.0/24       10.1.16.6                0    100      0 i
*> 7.7.7.0/24       0.0.0.0                  0         32768 i

R1(config-router)#neighbor 10.1.17.7 next-hop-self

R7#ping 5.5.5.5 source lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
Packet sent with a source address of 7.7.7.7
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/52/72 ms

0 comments:

Post a Comment

 
Top